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Introduction 

Welcome to BarCoder 

Before groups of documents are placed into a scanner, multi-function device with 

scanning capabilities or even a fax machine, overall efficiencies and improved 

accuracy can often be obtained by doing appropriate planning and document 

preparation: 

 How will the pages belonging to each document be separated from others in 

the group?   

 Separated at the time of scanning or must it be done later? 

 How can each of the documents be indexed accurately and efficiently as each 

document is captured in DocuPhase?   

 Can accurate barcoded data be used to provide automatic indexing or must 

other means be employed? 

 Is it practical to do any document preparation prior to scanning? 

 Note that internal staff can be trained to follow disciplined procedures 

(sometimes); However, public points of submission can rarely be controlled. 

 Is it possible and practical to pre-encode information on turnaround 

documents you sent out for return? 

 Pre-encoding allows each document scanned as a group of pages to be 

automatically recognized, separated and/or indexed by using accurate 

barcodes or OCR on high-quality imaged text; However, the quality of 

documents and resulting images are not always reliable or easy to control – 

Requiring alternative approaches to resolve problems. 

As you plan and prepare your capture processes to address document separation, 

document identification and indexing as well as alternative approaches required to 

handle exceptions, the BarCoder utility product may prove to be a valuable tool 

during your document preparation and capture process. 

 

BarCoder is able to: 

 Create Separator pages to go between the documents in a group with 

printed Patch-codes (i.e., large horizontal bar codes) or barcodes (e.g., 3 of 9 

or 128 barcodes) that can be automatically recognized and separate each of 

the documents in the group. 

 Provide Indexing Information in Barcode format as well as text format 

on the separator sheet that can be reliably read and used to index each 

document in the group. 

 Both Patch-codes and Index Information Barcodes may appear on the 

same document separator page it creates. 

Horizontal
Patch-Code

Separator Code

3 of 9 Barcodes
Bearing Data Values



   

BarCoder Advanced User Manual 6.1              Page 5 of 31 

BarCoder reduces the time necessary for document preparation and it can reduce 

indexing effort.  BarCoder is compatible with industry-standard barcode readers. 

By combining easy to implement scanning procedures with user-defined patch-codes 

and barcodes, BarCoder increases the productivity of your pre-scanning process.  

 

Purpose and Assumptions 

This manual has been written for advanced user to prepare them to install, configure 

and use the BarCoder product.   

End-Users of BarCoder, ScanDox and/or DocuPhase can use sections of this manual 

to understand how to create and print barcoded document cover sheets. 

The following are assumptions made with regard to the advanced reading audience 

for this guide: 

 The reader has received at least one day of DocuPhase provided training. 

 The reader has used the DocuPhase software product for a period of no less 

than one month. 

 

Foundational Terminology 

The following key terminology that appears in this document are defined to aid the 

reader in case they are unfamiliar with these terms. 

Data Extraction:  Data Extraction allows for the collection and manipulation 

(extraction) of data by use of a computer. BarCoder generated document separator 

pages contain barcoded values along with corresponding text field names that can be 

used to provide index field data that describes each document. 

OCR. Optical Character Recognition (OCR) is a technology that allows a computer to 

recognize text from digital images of paper and then translate that text into a data. 

Barcodes. Barcodes are special machine print codes for storing information. This 

information is easily and accurately extracted by auto-indexing tools, such as 

ScanDox and Xtractor.   

Patch-codes are a special type of barcode which have bars that are aligned 

horizontally which are used to identify document separator pages. 

Subpage Processing. Xtractor can separate and process multiple documents with 

the use of a properly configured Document Separator such as generated by 

BarCoder. 

Note: Subpage Processing provides the ability to split multipage documents 

into multiple separate documents.   

Likewise, groups of documents with separator pages may initially be captured 

as if they are one document, but the BarCoder generated separator pages 

placed between the documents prior to scanning can be used to split the one 

group-document into multiple separate documents as well as provide 

barcoded index-field values to index each split-document appropriately. 
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Client Support Services Contact Information 

DocuPhase is committed to providing quality service and support for our customers. 

If you are experiencing difficulty with your DocuPhase software, please let us hear 

from you so we can help. 

Client Support Services are provides as part of your Maintenance Program. Enhanced 

support programs are available upon request. The standard support feature set 

includes: 

 Product Updates and Upgrades 

 Telephone and Email support during local business hours 

 Remote Connect Support during local business hours 

 

You may: 

 Contact us by email at support@DocuPhase.com. 

 Reach us by phone at (727) 441-8228. 

 Reach us by fax at (727) 444-4419. 

 Find us online at www.DocuPhase.com/support. 

mailto:support@idatix.com
http://www.idatix.com/support
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BarCoder Product Overview 

BarCoder reduces the time necessary for document preparation.  By combining easy 

to implement scanning procedures with user-defined barcodes, BarCoder increases 

the productivity of your pre-scanning process.  

BarCoder fulfills the promise of streamlining your enterprise operations by reducing 

the resources needed to prepare documents prior to scanning. BarCoder is 

compatible with industry-standard barcode readers. 

 BarCoder makes use of straightforward procedures to create user-defined 

barcodes thereby reducing the time necessary for document preparation in the 

scanning process.  

 BarCoder allows simple creation of barcode separator sheets for automating the 

document indexing process.  

 BarCoder also allows execution of database look-up to auto-populate index fields 

greatly reducing data entry and further ensuring accuracy.  

 BarCoder is also ideal for customers who wish to scan using a Multi-Function 

Device (MFD) where the barcoded coversheet it generates remains with the 

document in a TIFF-formatted file that is processed, indexed and submitted to 

DocuPhase by Xtractor. 

 BarCoder is completely integrated with DocuPhase and requires no programming 

or scripting to use.  

 BarCoder is application aware and automatically selects the correct cover sheet 

for any selected virtual file cabinet chosen for scanning.  

 By encoding document-specific information into a barcode, BarCoder increases 

the speed with which documents can be processed into the DocuPhase 

repository. BarCoder also allows users to place barcodes in a user defined space, 

select the 3 of 9 type or 128 type of barcode as well as the font and font size  

BarCoder’s features are easy to use with its icon-driven interface. This interface 

allows for rapid pre-scanning preparation of documents without the need for IT 

assistance or support. BarCoder delivers high performance by streamlining the 

document preparation process and increasing efficiency across the entire capture 

operation. 

By reducing or eliminating the need for manual keying during the pre-scanning 

process, BarCoder increases the accuracy in document handling as they are prepared 

for scanning. Field Access accelerators increase both the overall speed in which 

documents are prepared and the accuracy of data as it delivered to the correct 

DocuPhase Application Cabinet. 
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BarCoder Purpose – Overview Example 

Using BarCoder to select the DocuPhase Application cabinet where a batch of related 

documents of multiple pages of the same document, a separator cover sheet can be 

created by entering the appropriate Index Field values that each of the documents 

have in common, as shown below. 

 

In this example, several one page documents resulted from this single medical-office 

encounter and are they are being input via to a scanner controlled by ScanDox along 

with a number of other patient-information records for today’s office-visit 

encounters.  Since each encounter has one or many pages, a separate BarCoder 

separator sheet will keep the pages for each encounter separate and reduce the 

amount of manual indexing effort by: 

 Only having one set of indexing fields for each document in each ‘Encounter 

Batch’. 

 Only indexing one or a few of the indexing fields with the remaining index 

field automatically indexed by database lookups performed by BarCoder. 

 Only indexing none or one index fields with automatic indexing performed by 

OCR/Barcode reads by Xtractor or iDox and possible additional database 

lookups performed by Data Exchange as services in the background. 

 

The following illustration shows an ‘Encounter Batch’ with its separator Cover Sheet 

followed by three (3) one-page documents.   
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Should multipage documents be used or mixed with single page document, 

additional considerations and options can be applied. 

  

BarCoder Printed Cover Sheet Medical Information for this
Patent Encounter

XRAY for this 
Patient Encounter

EKG for this 
Patient Encounter

Cover Sheet for this 
Batch of Documents 

from this
Patient Encounter: 2223347
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Key Features 

The key features of BarCoder include: 

 Excellent Quality Barcodes 

 Reduced Document Preparation Time 

 Easy to Use 

 Intuitive Interface 

 Add Barcodes Without IT Support 

 No Programming Required 

 Increase Accuracy 

 Reduce Data Entry with Automatic Database Lookups 

 Ensure Data Integrity 

 Pull Data from Other Applications 

 

BarCoder Saves Time 

BarCoder reduces time necessary for document preparation.  Making use of 

straightforward procedures to create user-defined barcodes, BarCoder increases the 

efficiency of the pre-scanning process.  

 BarCoder can link with a pre-established template found in the DocuPhase 

repository and populate index fields with information.  

 Populating index fields with information is accomplished without manual data 

entry, thereby increasing the productivity and accuracy of the data capture 

process.  

 BarCoder is application-aware and automatically selects the correct cover sheet 

for any selected virtual filing cabinet chosen for scanning.  

 By encoding document-specific information into a barcode, BarCoder increases 

the speed with which documents can be processed into the DocuPhase 

repository. 

 BarCoder also allows users to place barcodes in a user-defined space, select the 

type of barcode, the font and font size, or use customized forms. 

 

  



   

BarCoder Advanced User Manual 6.1              Page 11 of 31 

BarCoder Increases Accuracy 

By reducing or eliminating the need for manual keying during the pre-scanning 

process, BarCoder increases the accuracy in the handling of documents as they are 

prepared for scanning.  

 Field Access Accelerators increase both the overall speed in which documents are 

prepared, and  

 Increases the accuracy of the data as it is delivered to the correct index field.  

 

Working with BarCoder 

The User Interface for BarCoder consists of six areas: 

1. Main Menu Bar. 

2. Application Selection Panel. 

3. Index Entry Panel. 

4. Print Option. 

5. Preview Option. 

6. Status Bar. 
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Main Menu 

The main menu bar contains three drop-down menus: File, Tools, and Help.  

 

 

The following table describes the elements of the BarCoder Main Menu. 

Element BarCoder Main Menu Description 

File 

 
 

The File menu consists of three options: 

 Page Setup, 

 Logout, and  

 Exit. 

 

File>Page Setup 

 

The Page Setup Options displays the basic printer 

options such as paper size, source, orientation and 

margin options. 

 

Note: Use the Page Setup option to make necessary 

adjustments.  

Additionally, to make printer property and settings 

changes, select Printer. When you are finished, select 

OK. 
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Element BarCoder Main Menu Description 

File>Logout 

 

Provides the ability to log out the current user. 

Note: A Question dialog displays asking Are 

you Sure you to want to log out. Select Yes to 

log out, or No to cancel. 

 

File>Exit 

 

Provides the ability to exit BarCoder without logging 

out. 

Note: When using the exit option, the user will 

not have to reenter their user credentials in the 

log in dialog. 

Tools 

 

The Tools Menu consists of four options:  

 Display Fields,  

 Sticky Fields,  

 Lookup Fields, and  

 Options. 

 

Tools>Display Fields 

 

Provides the ability to choose which Index Fields will 

display on the Index Entry Panel. 

 

Note: To make a selection, click the checkbox 

next to the field name and then select OK. 
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Element BarCoder Main Menu Description 

Tools>Sticky Fields 

 

Provides the ability to retain the information in the 

selected Index Field after a BarCoder cover sheet has 

been printed.  

 

Note: To make an Index Sticky, click the checkbox 

next to the Index Field and select OK. 

Tools>Lookup Fields 

 

Provides the ability to specify an Index Field to serve 

as a key for remote entrance to another system, as 

well as enables you to use the value of one BarCoder 

Field to look up the values of other BarCoder fields. 

 

Note: This remote system can be any ODBC compliant 

data source.  

Additionally, once you have selected the lookup field, 

the Configure Lookup dialog displays providing the 

ability to define the ODBC connection. 
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Element BarCoder Main Menu Description 

Tools>Options 

 

Provides the user with the ability to work with 

BarCoder Templates. Select from the General, Fonts 

and Images tab. 

 

Display Field Labels 

and Entered Text 

Provides the ability to configure BarCoder to print the 

field labels (DocuPhase Indexes) as well as the 

entered text. 

 

Restore System 

Defaults 

Provides the ability to populate the dialog with preset 

system default values. 
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Element BarCoder Main Menu Description 

Tools>Options>Fonts 

 

Provides the ability to change and adjust the font type 

and size printed on the barcode page, as well as the 

barcode type, size and spacing. 

 

Text 

 

Provides the ability to select various fonts from a drop 

down menu. 

 

Size 

 

Provides the ability to select various font sizes from a 

drop down menu. 
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Element BarCoder Main Menu Description 

Barcode 

 

Provides the ability to select various barcode types 

from the drop down menu. 

 

Note: The sample pane displays the selected 

barcode. Furthermore, the Barcode field and 

the Type field must be synchronized.  

For additional information review the following 

website: 

http://www.mecsw.com/specs/speclist.html.  

Type 

 

 

Provides the ability to select various barcode types 

from the drop down menu. 

 

Note: The Barcode field and the Type field 

must be synchronized.  

For additional information, please review the 

following website: 

http://www.mecsw.com/specs/speclist.html. 

http://www.mecsw.com/specs/speclist.html
http://www.mecsw.com/specs/speclist.html
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Element BarCoder Main Menu Description 

Size 

 

 

Provides the ability to choose various barcode display 

sizes from the drop down menu. 

 

Note: The minimum requirements for barcodes 

are: 

 Type: Code 39, Code 39 Mode 43 and Code 

128  

 Size:  30pt 

 

Gap 

 

 

Provides the ability choose various barcode spacing 

gaps from the drop down menu. 
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Element BarCoder Main Menu Description 

Tools>Options> 

Images 

 

 

Provides the ability to change or adjust the placement 

of the patch code that appears on the printed barcode 

page.  

 

Top Separator Image 

 

 

Provides the ability to place the printed barcode of the 

top of the page.  

 

Note: By default, the barcode is placed in the 

top portion of a printed page. To change the 

image, select Browse. 

Bottom Separator 

Image 

 

 

Provides the ability to place the printed barcode at the 

bottom portion of the page. 

 

Note: To change the image, select Browse. 

Left Separator Image 

 

 

Provides the ability to place the printed barcode at the 

left portion of the page. 

 

Note: To change the image, select Browse. 
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Element BarCoder Main Menu Description 

Right Separator 

Image 

 

 

Provides the ability to place the printed barcode at the 

right portion of the page. 

 

Note: To change the image, select Browse. 

Help 

 

 

Provides the BarCoder version number and DocuPhase 

contact information. 

 

 

Print 

 

 

Provides the ability to print the defined barcode sheet. 
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Element BarCoder Main Menu Description 

Preview 

 

 

Provides the ability to preview the barcode sheet prior 

to printing. 
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BarCoder Configuration 

Configuring Lookup Fields 

When you select an index field as a lookup field, the Configure Lookup dialog is 

displayed. From here, you will need to configure the ODBC connection, write the 

appropriate query and map the associated fields.  

Note: Please contact your Database Administrator for further details.  

1. Select Tools>Lookup Fields. 

 

2. Select the appropriate Lookup Field. 

 

Note: The Configure Lookup Dialog displays. 

3. Define the DSN, User and the Password. 
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4. Select Query. 

 

 

5. Define the Query Criteria. 

 

 

6. Select Mapped Fields. 

 

 

7. Select Add Map. 
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8. Select the desired Query Field entry and choose the appropriate Application 

Field Entry. 

 

Note: To remove a mapped field, select Remove Map. 

 

9. Select OK. 
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Creating a BarCoder Cover Page 

1. Select the desired application from the Application Selection Panel. 

Note: The associated index fields are displays in the Index Entry Panel. 

 

2. Define the Index Values appropriately. 

 

 

 

3. Select Preview. 

 

Note: This will enable you to verify the content. 

 

4. Select Print. 

 

  

  Note:  If a Lookup Field has been configured, type in the index 

value of the defined Lookup Field and the mapped index fields are 
automatically populated. 
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Appendix A:  BarCoder Installation 

Note:  During the iDatix to DocuPhase branding transition in DocuPhase 6.0 many of 

the directory and internal components are still named the same and will retain their 

previous ‘iDatix’, ‘iSynergy’ and other module names.  Temporarily, a mix of the old 

and new names will reflect this transition. 

Prerequisites & Minimum Requirements 

The following BarCoder installation consideration topics are documented in the 

following locations: 

 Minimum Requirements: See DocuPhase Prerequisites Guide 

 Prerequisites: See DocuPhase Prerequisites Guide 

 BarCoder Installation from .MSI:  

 BarCoder Application 

See:  DocuPhase Installation & Upgrade Guide,  

Topic:  Installing the Optional Components. 

 

Logging in to BarCoder 

Once BarCoder has been installed, you have the ability to log into the application.  

To log in, follow this procedure. 

1. On your Desktop, navigate to the BarCoder shortcut icon. 

 

 

 

  Note:  If you do not have the BarCoder shortcut icon, navigate 
to Start>All Programs>iDatix>BarCoder. 
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2. Tab to User Name text field and enter your User Name. 

3. Tab to Password text field and enter your Password. 

4. Click the Server button, then Select your Server from the list. 

Note: The Alias Manager dialog displays. 

5. Define your Server in the Server Name or URL field. 

 

 

Logon to BarCoder
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6. Select Load. 
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7. Select OK. 

 

 

8. Click the Login button on the Login to BarCoder dialog. 

Note: The BarCoder application launches. 
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Appendix B – Code 39 Specification 

Barcode Style: Code 39 (sometimes called “3 of 9”, “3/9” and USD-3) is a discrete 

barcode. This means that a fixed pattern of bars represents a single character.  

Each character is made up of 9 bars - 3 of which are wider than the others. (In this 

context a bar can be the printed black bar or the white space between the bars.) A 

single character therefore consists of 5 black bars and 4 white bars, as shown below.  

 

The ratio of the bar widths can range from 2.2:1 to 3:1. To read a barcode reliably 

the decoder must be able to differentiate between the wide and narrow bars. In 

practice it is better to use barcodes close to the 3:1 ratio which allows nearly a 50% 

bar width error to occur before ambiguity occurs.  

The space between each barcode character is called 'The inter-character gap'. Its 

width is undefined but is usually equivalent to a narrow white bar.  

The widths of the wide and narrow sets of elements should all be the same but in 

practice most printing processes incur 'ink spread'. This widens the bars at the 

expense of the spaces. This effect is most noticeable on narrow elements sometimes 

making the barcodes very difficult to scan with some decoders.  

The Code-39 barcode symbols support 43 characters plus an additional character 

used as a delimiter or start/stop character. The start/stop character always occurs as 

the first and last character in a complete barcode and is represented in human-

readable text by the * character.  

  

 Comment:  The Code-39 character set includes the following 43 characters: 
   1234567890ABCDEFGHIJKLMNOPQRSTUVWXYZ - . $ / + % SPACE 
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Appendix C – Bar Width Configuration Table 

This table shows the bar configuration for each character in the Code 39 set. Note 

that the * character is used only for the start/stop character. It must be the first 

and last character appearing in the complete barcode. (Decoders do not usually 

transmit this character as part of the data string.) 

 

 

 

 


